You are here
Home > python

centos pyenv python3.5 urllib BeautifulSoup

yum remove audit

yum install gcc

yum install libxslt-devel libxml2-devel

pyenv install --list

yum install bzip2-devel.x86_64

yum install openssl-devel.x86_64

 pyenv install 3.5.7

pyenv local 3.5.7

pyenv global 3.5.7

pip install beautifulsoup4

pip install --upgrade pip

pip3 install lxml

centos7.4 先安装pyenv 再安装3.5.7 安装 lxml 需要c库,所以选择版本时,不要选错,第一次安装时,选了个pypy3.5.7-10.0的版本,后面安装bs和lxml几次错误,坑不小啊。。。

Top